Net Framework (windows)

Répondre
Avatar du membre
vladimir
Administrateur du site
Messages : 20
Enregistré le : 21 mai 2019, 21:21
Localisation : Maine et Loire
Contact :

Net Framework (windows)

Message par vladimir » 01 oct. 2019, 08:51

La version actuelle d'opensimulator nécessite au minimum la version de Net Framework 4.6 .

Les mises ajour de windows peuvent avoir fait passer de 4.6 a 4.8 ,dans ce cas il vous faudra utiliser une version de patchée de opensimulator (c'est ce qui se passe actuellement avec la mise a jour 1903 de windows 10) .

Pour déterminer quelle version vous utilisez ,vous pouvez télécharger et exécuter ce petit utilitaire : https://aofoyg.bl.files.1drv.com/y4mE8G ... oad&psid=1

Au cas ou vous auriez une installation existante d'Opensimulator et que windows à fait la mise a jour de Net Framework et ne démarre plus ,il existe une solution très simple :

Ouvrez avec Note pad ++ le fichier OpenSim.exe.config ou dans tout autre éditeur de texte .


Cherchez ces lignes ci :

<runtime>
<loadFromRemoteSources enabled="true" />
</runtime>




Remplacez par ce code ci :

<runtime>
<loadFromRemoteSources enabled="true" />
<useLegacyJit enabled="1" />
</runtime>


Redémarrez votre simulator et TODO !!!!!


N.B:

Si vous utilisez la version patché ,tout les fichiers config sont déja patchés .

Prodyck
Messages : 8
Enregistré le : 30 juin 2019, 20:06

Re: Net Framework (windows)

Message par Prodyck » 04 oct. 2019, 08:40

A revoir : le lien pointe vers une page introuvable

Répondre